MOBILE DATA COLLECTION: A PRIMER

GENE STROMAN, PUBLIC LIFE INTERN
SF PLANNING DEPARTMENT, SPRING 2015
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>INTRODUCTION</td>
<td>7</td>
</tr>
<tr>
<td>ADMIN SETUP</td>
<td>10</td>
</tr>
<tr>
<td>GEODATABASE SETUP</td>
<td>12</td>
</tr>
<tr>
<td>MAP SETUP</td>
<td>18</td>
</tr>
<tr>
<td>MAP SERVICE SETUP</td>
<td>22</td>
</tr>
<tr>
<td>MOBILE DEVICE SETUP</td>
<td>30</td>
</tr>
<tr>
<td>DATA COLLECTION</td>
<td>32</td>
</tr>
<tr>
<td>POST-COLLECTION</td>
<td>34</td>
</tr>
<tr>
<td>CONCLUSION</td>
<td>38</td>
</tr>
<tr>
<td>RESOURCES</td>
<td>40</td>
</tr>
<tr>
<td>APPENDICES</td>
<td>43</td>
</tr>
</tbody>
</table>
Admin Setup

Geodatabase Setup

Map Setup

Map Service Setup

WORDS, GRAPHIC DESIGN, AND LAYOUT BY GENE STROMAN
INTRODUCTION

WHY MOBILE DATA COLLECTION?

The Citywide division of the San Francisco Planning Department conducts a wide range of studies that could benefit from the added efficiency of a Mobile Data Collection platform. With potential to cut out the most time-consuming steps from the traditional “paper, pencil, and clipboard” workflow, the use of tablets and Esri collector seemed optimal to aid in the Public Life Studies that the department continues to perform on increasingly varied spaces across the City of San Francisco.

Switching to a Mobile Data Collection platform, the Department could save time on the data collection setup, allowing more time for analysis and production. With this in mind, Teresa Ojeda and Robin Abad Ocubillo applied for a Friends of City Planning grant in August 2014 to purchase nine iPads for the department. In December 2014, the funding was awarded.

The Mobile Data Collection (MDC) Pilot was carried out between January and July, 2015, with the majority of troubleshooting and production taking place after the iPads arrived in April 2015. A version of this report was presented at the Citywide Department meeting on July 6, 2015.

The author would like to thank the following individuals for their expertise in helping to troubleshoot and guide the structure of this project: Robin Abad Ocubillo, Teresa Ojeda, Mike Webster, Mike Wynne, and Brian Quinn.

As Esri collector is a relatively new application, there is yet to be a comprehensive, centralized, and accessible resource for the setup. This manual is the result of several months of sorting through Esri’s help forums and scattered online resources in the attempt to understand and optimize the setup for a Mobile Data Collection project.

It is the hope of the author that by following the steps in this manual, one should be able to setup a Mobile Data Collection project. Although the tutorial uses Activity Mapping, a Public Life Studies data collection method, as an example, mobile data collection has potential for a much wider range of uses with exciting implications for the Planning and Architectural disciplines.
**FIGURE 1** "OLD-SCHOOL" WORKFLOW

1. Design Forms
2. Print & Assemble Packets
3. Distribute Forms
4. Data Collection
5. Enter totals into Google Forms
6. Transcribe Data Attributes
7. Data Cleanup
8. Create Geodatabase & Feature Classes
9. Transcribe Data Points
10. Join table to shapefile
11. Merge all shapefiles
12. Scan Hardcopies
13. Geospatial Analysis
14. Numeric Analysis
15. Graphic Production
FIGURE 2 "NEW-SCHOOL" WORKFLOW
In order to move through this tutorial and properly set up a mobile data collection project with secured services (editor tracking), you will need to be assigned login credentials for the following items: (1) ArcGIS Online, (2) SDE Admin, and (3) SDE User. If you plan to have more than one person collecting data, each user will need to have his or her own AGOL and SDE user credentials. Please contact Brian Quinn (DT) to set up these accounts and to setup a deployment strategy.

**FROM YOUR DESKTOP ...**

**Connect to ArcGIS Server**

1. Open up ArcCatalog
2. Scroll to the bottom of the Catalog Tree, and click on “GIS Servers” > “Add ArcGIS Server”
3. In the “Add ArcGIS Server” dialog box, click on “Administer GIS Server” > “Next”
4. Fill out all the corresponding fields in the properties dialog box using the SDE Admin Credentials:
   - **Server URL:** http://sfgis-svc.sfgov.org:6080/arcgis/admin
   - **Username**
   - **Password**
   - Leave all other fields with default values

**Connect to CPC Enterprise Geodatabase**

1. In ArcCatalog, scroll to the bottom of the Catalog Tree, and click on “Database Connections” > “Add Database Connection”
2. Fill out the corresponding fields in the properties dialog box using the SDE Admin Credentials: **SEE APPENDIX 3**
   - **Database Platform:** PostgreSQL
   - **Instance:** sfgis-svc.sfgov.org
   - **Authentication Type:** Database authentication
   - **Username**
   - **Password**
   - **Database:** cpc_dat0
**IN ARCCATALOG** ...

**01 Set up Domains**

1. Right click on your SDE Geodatabase in the Catalog Tree > “Properties”
2. Navigate to the “Domains” tab
3. Fill out to the table at the top of the dialog box with the categories of drop-down items you’d like to see attached to fields in your final data collection table
   **Example:**
   - Domain Name: Gender
   - Description: Gender of observed pedestrian
4. Choose “Domain Properties” for the domain you just created
   - Select “Text” for field type
   - Most domains will use the “Coded Values” domain type. This is what will be used to create a drop down list in each of the fields in your final attribute table
   - Do not change split policy or merge policy from default values
5. If you selected “Coded Values” as your domain type, fill out “Coded Values” table at bottom of the dialog box.
   - For the above example of a “Gender” domain, the coded values, or set answers, will be “Male” or “Female”.
   - **TIP:** Use simplified abbreviations or numbers to serve as a code, as well as a description (how you want to see the text displayed in a drop down list) in the “Description Field” **SEE APPENDIX 2**

An enterprise geodatabase and its associated feature classes serve as the foundation for all subsequent processes in setting up a Mobile Data Collection project. Consequently, it is extremely important to be intentional and precise in its setup. One feature class is to be created for each data type that a user is looking to map and collect attributes for. The fields of each feature class correspond to a list of a geodatabase’s domains.
**FIGURE 3 GEODATABASE SETUP**

**STEP 1**
In ArcCatalog, connect to an Enterprise Geodatabase (SDE) to house all of the data you will be collecting in field. It is important that all files created from this point on live in this Geodatabase, as the edited properties will affect all associated files.

**STEP 2**
Open up the Properties dialog box for the Enterprise Geodatabase. Within the “Domains” tab, setup values for each of the data categories you are looking to observe in field. All text-based field types will have “Coded Values” domain types. Assign a list of coded values for each of the domains. These are the options a data collector will be able to select from on a drop-down list. Assign unique codes for each option, as well as a Description (this is the way the text will appear to the data collector).

**STEP 3**
Create new Feature Classes (Points) for each of the data point classifications you are looking to collect. In the properties box for each of these Feature Classes, create new fields and assign corresponding domains (the set of drop-down options you intend the data collector to see underneath each of the fields).
Example:
- Code: FMAL
- Description: Female

6. Complete these steps for each domain category you would like to use in your final table
- Click on “Apply” and then “OK” to save changes and close out of dialog box

Create a Feature Dataset
1. In ArcCatalog, navigate to local connection to SDE.
2. Right click on SDE > “New” > “Feature Dataset”
- Enter a name for the Feature Dataset
  Example: Annie_Data
3. Select a Coordinate System:
   NAD_1983_StatePlane_California_III_FIPS_0403_Feet

Create a Feature Class
1. Right click on newly created Feature Dataset > “New” > “Feature class”
2. Choose a name and alias for your feature class
   Example: Pedestrians
3. Choose a “Type” from the drop down list > For the purposes of Activity Mapping, choose “Point Features”
4. Select the same Coordinate System as you did for the Feature Dataset: NAD_1983_StatePlane_California_III_FIPS_0403_Feet
5. Click through the next few screens until you get to the dialog box with “Field Names” and “Data Types”
6. Type in all of the fields you would like to appear in your final table and choose the appropriate data type for each entry
   - TIP: Keep field names short and use underscores instead of spaces
7. Click “Finish”
8. Complete these steps for every feature class you would like to include in your data collection map.

Configure a Feature Dataset
1. Set Privileges
   - Right click on a feature dataset > “Manage” > “Privileges”
   - Add all desired users > “Apply” or “OK” to save changes and close to dialog box
2. Add Global IDs
   - Right click on a feature dataset > “Manage” > Add Global IDs
3. Enable Versioning (automatically creates version management tables for the Feature Dataset)
   • Right click on a feature dataset > “Manage” > “Register as Versioned”
   • Check the box next to “Register the selected objects with the option to move edits to base” and click “Ok”

4. Enable Archiving
   • Right click on a feature dataset > “Manage” > “Enable Archiving”

5. Create Attachments
   • Right click on a feature dataset > “Manage” > “Create Attachments”

6. Enable Editor Tracking
   • Right click on a feature dataset > “Manage” > “Enable Editor Tracking” > “Yes”
   • If you wish to choose the names given to record your ‘Creator’, ‘Create Date’, ‘Last Editor’, and ‘Last Edit Date’ fields, right click on a Feature Dataset > “Properties” > “Editor Tracking”
     • TIP: Avoid spaces or leading numbers
   • Dates are set to UTC time (Coordinated Universal Time) by default.
     • Although local database time is an option, Mobile Data Collection will not let you use local Database Time. Time will have to be reformatted post-collection

Assign Domains
1. Right click on your feature class in the Catalog Tree > “Properties”
2. Navigate to the “Fields” Tab
3. Click on the name of a Field

4. Fill out the “Field Properties” table at the bottom of the dialog box
5. Click on the box next to “Domain” and select a domain from the drop down list that you would like to associate with your field

Example:
• Field Name: Gender
• Domain: Gender

6. Complete these steps for each of the fields you created
7. Click on “Apply” and then “OK” to save changes and close out of the dialog box
**IN ARCMAP ...**

**Test Feature Class**

1. Open up ArcMap
2. Add newly created feature class to map using the “Add Data” button
3. Right click on feature class in Table of Contents > “Edit Features” > “Start Editing”
4. Open “Create Features” window > Select your feature class > Click anywhere on your map to create a feature point
5. Open “Attributes” window for new feature
6. For each field, click on the box next to field name, and make sure values in drop down list are accurate
7. If you wish to save data points, be sure to save edits (Click on “Editing” in the Editor window, and click “Save Edits” from the drop down list) before closing your editing session
Create a Base Map (Service 1)

1. Open ArcMap, and create a blank .MXD file

2. In ArcMap, import shapefiles (“Add Data”) that will help provide physical context to the study site

Example:
- Curbs
- Street Labels
- Parcels
- Address Labels

3. If your data collection will be focused on a specific site, it might be helpful to bring a site plan into GIS
   - .TIF (raster-based image) or .DWG (vector-based line work; higher quality) of a more detailed site plan
   - Reference this file to the globe using the Georeferencing Toolbar

4. Select only the features within the extents of your survey area using “Select by Location” and export to the SDE as new shapefiles

5. Add new shapefiles to the map, and delete old shapefiles

6. Set symbology of all shapefiles in map (Right click on layer > “Properties” > “Symbology”)

7. Set layer order of all shapefiles in map by clicking on a layer and dragging it up or down in the Table of Contents

The process of creating a map to use in-field involves creating two separate services to upload online: (1) a read-only basemap containing contextual elements, and (2) a data collection map containing the feature classes you hope to record in-field.

• For .DWG: Once you’ve georeferenced this layer, make sure to assign it a projection using the “Project” tool in the toolbox (select the same coordinate system you assigned to the document at the beginning of this exercise (NAD_1983_StatePlane_California_III_FIPS_0403_Feet))
8. Save this .MXD as “Service_1_Base.MXD”

Create a Data Collection Map (Service 2)

1. Open ArcMap, and create a blank .MXD file
2. Using the “Add Data” button, add all of the feature classes you created in Part 1 (Geodatabase Setup) from the SDE Geodatabase
3. Set symbology of all feature layers in map
4. Set layer order of all feature layers in map by clicking on a layer and dragging it up or down in the Table of Contents
5. Save your .MXD as “Service_2_Data.MXD”
STEP 1
Two different map services must be set up in ArcMap. For each service, bring in the relevant layers using the “add data” tool:
- **Service 1** is made up of the feature classes setup in geodatabase setup. These are the data points that a user will be collecting in-field.
- **Service 2** is made up of a series of shapefiles that will serve as a basemap, helping to contextualize a user’s surroundings.

STEP 2
Once you have set up both services in two separate .mxd documents, publish the service to a server via ArcMap.

STEP 3
After both services have been hosted on a serve, set service properties and combine services into an ArcGIS Online Map document.

(1) SF Multitenant Server and / or
(2) ArcGIS Online
While a user has the option to host services on ArcGIS Online, SF Planning uses local servers to maintain control of data in Esri Collector. The workflow we’ve decided on requires a publisher-level connection to the SFGIS multitenant server, rather than ArcGIS Online, which requires “credits”.

In order to carry out the steps in Part 3, you must first have an ArcGIS Online account. While we will not be using ArcGIS Online to host services, it will still be used to combine services, tweak map properties, and share maps.

If you do not already have an ArcGIS Online login, ask your administrator for access and to be added to the “SF Planning Data Collectors Group”.

**IN ARCMAP ...**

**Publish Basemap (Service 1)**

1. In ArcMap, click “File” > “Share As” > “Service” > “Publish Service”

2. Choose a connection:
   - To publish to SDE, click on arcgis on sfgis-svc.sfgov.org_6080 (admin)
   - If you wanted to instead publish to ArcGIS online, you would click on “My Hosted Services (City and County of San Francisco)”
   - **NOTE:** must already be signed in to AGOL for this to option to appear

3. Click on “Use existing folder”, and select “CPC” from the drop-down list

**Set service properties** in Service Editor dialog box:

1. Parameters:
   - Change “Maximum number of records returned by the server” from “1,000” to “10,000”

2. Capabilities:
   - Unselect “KML”

3. Item Description:
   - Fill out all relevant boxes (will not let you publish with empty item description)

4. Sharing:
   - Choose who you would like to share your service with.

5. Click on “Analyze” to see if there are any errors before publishing
Assemble services into ArcGIS Online Map

Download map to device

All data collected online is sent back to Enterprise Geodatabase

Enterprise geodatabase hosted at SF Multitenant Server

FIGURE 5  MAP SERVICE SETUP
6. Click on “Publish” to publish service with updated properties to the server
   • A message will appear reading “The service has been published successfully
7. Save and close your .MXD

**Publish Data Map (Service 2)**

1. In ArcMap, click File > Share As > Service > Publish Service
2. Choose a connection:
   • To publish to SDE, click on “arcgis on sfgis-svc.sfgov.org_6080 (admin)”
   • To publish to ArcGIS online, click on “My Hosted Services (City and County of San Francisco)”
   • **NOTE:** Must already be signed in to AGOL for this to option to appear
3. Click on “Use existing folder”, and select “CPC” from the drop-down list

**Set service properties in the Service Editor dialog box:**

1. Parameters:
   • Change “Maximum number of records returned by the server” from “1,000” to “10,000”
2. Capabilities:
   • Unselect “KML”
   • Select “Feature Access”
3. Feature Access:
   • Check “sync” to enable access without cellular connection
   • Ensure that all options are checked
4. Item Description:
   • Fill out all relevant boxes (will not let you publish with empty item description)
5. Sharing:
   • Choose who you would like to share your service with
6. Click on “Analyze” to see if there are any errors before publishing
7. Click on “Publish” to publish service with updated properties to the server
   • A message will appear reading “The service has been published successfully
8. Save and close your .MXD
**IN ARCGIS SERVER ...**

**NOTE:**

1) If there is a change to structure of the feature data (anything other than creating or editing data points), you must republish service in ArcMap.

2) If making changes to Feature Datasets or Feature Classes within ArcCatalog, be sure to click on the “Stop” icon next to a map service in the ArcGIS Server Manager. Otherwise, a message will appear saying there’s a lock on database schema.

1. Login to ArcGIS Server Manager
   - Enter the following URL into your browser: https://sfgis-svc.sfgov.org:6443/arcgis/manager/index.html#f=cpc

2. Enter SDE Admin Credentials: See Appendix 3

3. Within ArcGIS Server Manager, Login to ArcGIS Online
   - Navigate to “Services” > “Sharing”, and enter your AGOL Credentials See Appendix 3 to the portal

4. Navigate to the “CPC” folder (click on “CPC” on the left side of the page)

**Edit Service Properties**

1. If you are not already on the “Manage Services” page, click this link at the top left hand corner of the page

2. Click on the pencil icon next to whichever map service you’d like to edit

3. Going through each of the tabs on the left side of the page, make changes to properties and click “Save and Restart” on the top right

**Edit Base Map (Service 1) Properties**

1. Set Sharing Properties by clicking on the person icon next to your new service

2. Unlock Database Schema by unchecking the “Lock Database Schema” option at the bottom of the Parameters tab. (This will allow you to make changes to the service from your desktop)

3. Click “Save and Restart” to save changes
07 Edit Data Map (Service 2) Properties

1. Set Sharing Properties by clicking on the person icon next to your new service
2. Unlock Database Schema by unchecking the “Lock Database Schema” option at the bottom of the Parameters tab. (This will allow you to make changes to the service from your desktop)
3. Click “Save and Restart” to save changes

08 Secure a service

• Only allow access to data with credentials
  • **NOTE:** This should only be done on the Data Map (Service 2)
1. Click on the lock icon next to the service you’d like to secure
2. In the “Edit Permissions” dialog box, click on “Private, available only to selected users”
3. Select which “roles” you would like to allow permission to. Make sure the following roles are checked:
   • cpc_publisher
   • cpc_user
4. Click “Save” to save changes and exit this dialog box
   • **NOTE:** Once a layer is secured, you will be asked to enter SDE Credentials to access it both in ArcGIS Online and in Collector
5. Any time you are making administrative edits to a service, you will need to enter SDE Admin Credentials
6. If opening a map in Collector to record data, you must enter SDE User Credentials

09 Hide all other users' data points

1. In ArcGIS Server Manager, click on the pencil icon next to the service you’d like to edit
2. Navigate to the Capabilities tab > Click on Feature Access (do not click on the checkbox, click on the word)
3. Uncheck “Query”
   • **NOTE:** Unchecking “Query” in the Feature Class menu allows a user logged-in to Esri Collector to only see features he or she created. If “Query” is checked and “Update “and “Delete” are unchecked, the user will have read-only access to features owned by other users
Part 3: Map Service Setup

• **NOTE:** Unchecking “Query” can only be done in ArcGIS Server Manager. Doing so in the service publishing window is greyed out.

4. Click “Save and Restart”

**IN ARCGIS ONLINE ...**

1. Enter the following URL into your Browser: https://www.arcgis.com/home/signin.html and login to ArcGIS Online using your AGOL Credentials. **SEE APPENDIX 3**

2. Click on “My Content”. After publishing your two services, you should see a Map Image Layer and a Feature Layer.

**Edit Base Map (Service 1) Properties**

1. Under “My Content”, click on the Map image layer > “Edit”

2. In the URL box at the bottom of the page, remove “:6080” (the port number) so that the URL reads http://sfgis-svc.sfgov.org/arcgis/rest/services/cpc/YourServiceName/FeatureServer

**Create a Data Collection Map that uses uploaded Feature Layers**

1. Click on “My Content”

2. Click “Create” > “Map”

3. Fill out the “New Map” dialog box

4. Click on “Add” > “Search for Layers”

5. Click the drop down menu next to “In” and select “My Content”

6. Click “Add” next to each layer needed in your map
   - Map Image Layer (Service_1_Base)
   - Feature Layer (Service_2_Data)

**Edit Data Map (Service 2) Properties**

1. Under “My Content”, Click on the Feature Layer > “Edit”

2. In the URL box at the bottom of the page, remove “:6080” (the port number) so that the URL reads http://sfgis-svc.sfgov.org/arcgis/rest/services/cpc/YourServiceName/FeatureServer
7. ArcGIS Online Maps will automatically load a template basemap with a limited range which may be insufficient for the purposes of Activity Mapping. For ‘Unlimited Zooming’, add the SFGIS Public Image Service.
   - Click on “Add” > “Add Layer from Web” > From the drop down list, select “An ArcGIS Server Web Service”
   - Paste a URL for an image service into the URL field and click “Use as Basemap”
   - Close the dialog box by clicking “Add Layer”
     • **NOTE:** Adding this as a basemap will prevent a map from being accessed without cellular connection.

8. Click “Save” to save map

9. Click “Share” to share map with select organizations (share with everyone)

13. **Edit Map Properties**
1. Navigate to “My Content”
2. Find and click on the map you just created to edit the map’s properties
3. Click on “Edit”
4. Click on “Enable Offline Mode” in order to let people download your map to their device.
   - Maps using Web Services will not let you access a map without cellular connection
   - **SHARE:** Make sure layers are shared with intended users
   - **EDIT:** Make sure map is available offline
   - **EXTENT:** Click on “Set Extent” to choose where you would like your map to open up in Collector

14. **“Sideloading” a Custom Basemap**

Sideloading a custom basemap is a good option if you want to work around the ArcGIS Online templates which have zooming limitations.

1. Create a .TPK (Tile Package) to use as your own Basemap in place of the Esri default
2. Connect your mobile device to your computer with a USB and open up iTunes
3. In iTunes, navigate to the “Applications” tab, find the Esri Collector Application
   - Click the “Add” button and find the .TPK file you just created > Click on Apply
   • **NOTE:** If collector was already running, you will need to restart it in order to see your newly loaded basemap
4. Disconnect the Mobile Device, from your computer and open up the Esri Collector Application on your device.

5. After logging in, select a map you would like to view, and click on the “Basemaps” icon in the top right corner of the screen. See Figure 5.

- Your sideloaded basemap should appear under the “On Device” tab. Click this to select it as a basemap.
- **Tip:** When deleting downloaded maps (using sideloaded basemaps) from your device, Collector will ask if you’d like to delete the features or the basemap. Select only “features”. Otherwise you will have to re-load maps to your device.
This section outlines how to access ArcGIS Online content on your mobile device and how to set up a mobile device for optimal data collection. Functionality will differ depending on whether your map is setup for use with or without cellular connection.

**01 Customize Esri Collector Settings**
- **NOTE:** If you do not see map appear on your device, close the program and sign back in.

2. Open up Esri Collector on your mobile device
3. Click on the Preferences icon at the top center of the screen
   - Choose settings for the following:
     (1) Units of Measurement
     (2) Map Downloads and Sync
     (3) Collection Style
     (4) Collection Options
   - **TIP:** Under “Collection Style”, Select “single” to collect a single feature at a time, or “continuous” to collect similar features repeatedly.

**02 If you would like to Download a map for use without cellular connection**
- **NOTE:** If you do not see map appear on your device, close the program and sign back in.

1. While connected to the internet, click on the Cloud icon next to the offline map
2. Choose a basemap
   - Basemaps from previously downloaded maps will appear as well as any basemaps that you may have manually sideloaded onto the device
3. Choose your work area
   - Zoom in or out to choose the scale at which you would like to see your map
4. Click “Download” in the upper right hand corner of the application to download the map to your device
Part 4: Mobile Device Setup

**Internet Connection**

1. On mobile device, retrieve maps by signing into Collector using AGOL login
2. Open map
3. Collect data in the field
4. Data automatically syncs

**No Internet Connection**

1. On mobile device, retrieve maps by signing into Collector using AGOL login
2. Download map to device (with internet connection)
3. Collect data in the field
4. Manually sync data (with internet connection)
This section outlines how to bring the maps you assembled into the field and record public life data using a mobile device. This works the same whether you plan on collecting data with or without a cellular connection.

1. Open Esri Collector on your mobile device
2. Click on “ArcGIS Online” to login > Enter your AGOL credentials [SEE APPENDIX 3] > Click “Sign On”
3. Click on any map to open it
4. If you are opening a map that is “secured” you will be asked to enter your SDE credentials [SEE APPENDIX 3] (this is the information that will automatically populate the editor tracking fields in your data table)
   • **NOTE:** If you are connected to the internet, the map will open up at your current geographic location
   • If you would like to navigate to your map’s default extent (the study site), click on the Book icon on the top of the screen and select “Default Map Extent”
5. To Turn Layers on and off, find the Layers icon at the top of the screen and check/uncheck layers

### Place a new feature

**OPTION 1**

1. Swipe the panel on the right end of the screen towards the left [SEE FIGURE 6]
2. Click on the feature you would like to geocode (ie: Pedestrians)
3. Click anywhere on the map to place a point on the map (a red dot will appear)
   • **TIP:** If you hold your finger down for 3 or so seconds, a crosshairs will appear to help with precision [SEE FIGURE 6]

**OPTION 2**

1. Press anywhere on the map, and a box will pop up > Click on “Collect Here”
2. Select a feature class to collect
Part 5: Data Collection

02 Select Attributes

1. Mark all the appropriate attributes by clicking on boxes and choosing from the drop down list.

03 Add Attachments

1. After you’ve selected a location on the map to place your point and filled out the attributes, click on the camera icon at the top of the screen (icon will only be visible if attachments are enabled on one of the services in your map).

2. Select “Take Photo” or “Choose from Library”. This will attach the photo to that data point.

• **NOTE:** Adding attachments may be unadvisable when working without a cellular connection and also with devices with minimal storage.

FIGURE 8 DATA COLLECTION

1. Collectable layers (feature classes) appear on a tab at the right hand of the screen.

2. Instantly move to default extent and save places using the Bookmark icon

Crosshairs help to more precisely place a data point.
This section explains how to bring the data collected in Part 5 into ArcGIS online, and from there onto your desktop computer. The post-collection workflow can differ depending on whether or not the data collection map was set up for use with a (1) cellular connection or (2) no cellular connection.

At the end of this section, you will have successfully accessed all collected data from your desktop, leaving you at a place to begin analysis.

**SCENARIO 01  If Data was collected with Internet Connection**

1. All data collected on a map while connected to the internet will automatically be accessible on the ArcGIS Online Map
2. All data collected on a map while connected to the internet will automatically be accessible in SDE

**SCENARIO 02  If Data was collected without Internet Connection**

1. In Esri Collector, navigate to the page with all of your maps (Click on the Maps icon in top left hand corner)
2. Ensure your device has a cellular or WiFi connection
3. Click on the cloud icon (there should be a red number next to the icon – this is the number of points that you have collected and have not yet been uploaded to ArcGIS Online)
   - The red number next to the cloud will disappear once the points have been successfully uploaded
4. In ArcGIS Online, find your data collection layer under “My Content” (ie: Annie_Data)
5. Click on the layer to open up its Item Details
Data collected in-field is transmitted to ArcGIS Online

Manually download data from ArcGIS Online as a shapefile to computer

Republish map service

Data collected in-field is transmitted to Enterprise Geodatabase

Access data by connecting to Enterprise Geodatabase on personal computer

FIGURE 9  POST-COLLECTION WORKFLOW
6. To download a shapefile of all data in this Feature Layer, click on “Export” > “Export to Shapefile”
   - Enter “Title”, “Tags”, and a “Summary” and click “Export”
   - Your shapefile will automatically be saved to your ArcGIS Online Account
     - In the Shapefile’s “Item Details” page, click on “Open”, and “Download” (will download as a .ZIP file)
7. Extract the .ZIP file
8. In ArcMap, open up a blank map document, and using the “add data” button, add the .shapefiles you’ve just downloaded
9. To download a specific Feature from ArcGIS Online, click on the arrow next to a Feature Name in the Feature Layer’s “Item Details” page > “Export to Shapefile”
10. After downloading data as a shapefile from ArcGIS Online, import data into Enterprise Geodatabase
   - **NOTE:** It is advisable to download the data after all data collection is complete
   - In ArcCatalog, find your SDE database
   - Right click on the SDE > Import
   - Fill out all the fields in the “Feature Class to Feature Class” dialog box
     - **Input Features:** the shapefile you’d like to import
     - **Output Feature Class:** the name of your new feature class

At this point, you will have access to all the data that has been collected in-field. Congratulations!
CONCLUSION

Mobile Data Collection offers many exciting implications for Public Life Studies and other data collection practices for planners. However, because the methodology is relatively new, there are many issues to explore and resolve before Esri Collector can be considered a more efficient tool to replace old workflows.

Currently, Esri Collector does not seem to be setup for optimal Public Life Studies data collection, in which a multitude of data points need to be collected quickly, precisely, and in a range of times and spaces. However, the tool has great potential for this method of data collection, and can be optimized by addressing a few minor limitations in future updates:

LIMITATIONS

1. **Speed:** While there is a way to configure Esri Collector settings for “Continuous” data collection (Settings > Collection Style: Continuous), filling out the attribute table for a feature is not as quick as one would like it to be (at least compared with collecting data on paper), especially when studying an area with a large amount of human activity.

2. **Precision:** All default maps only let you zoom in to a certain point, which isn’t close enough to record accurate positioning of humans in a plaza or on a street.

3. **Clutter:** During a Public Life Study, a user will collect anywhere up to 50 points in an hour within a very small map area. After a shift (typically 4 hours of collection), the map can become very cluttered and confusing to plot points. It would be less confusing to be able to only see the points that the observer is collecting for that hour. Checking the “Enable Time” box under Time Settings creates a time slider in the ArcGIS online map. But, it would be helpful have a Time Slider in the Collector application. Similarly, the ArcGIS online map has a “Filter Edits” option. There is no functionality in Collector to filter edits for a certain hour, day, or user.

OFFLINE MAPPING

While Offline Mapping is a possibility, the setup is rather cumbersome and not user-friendly. The update containing offline mapping has only been available as an option for about a year (v.10.2.2 – March, 2014), and there are many things to be worked out before the tool can be considered reliable. These assertions are supported by the innumerable threads on the Esri help forums in which users are having trouble performing relatively simple functions. Until these problems are addressed, it is strongly recommended that the
department use the workflow setup in this primer (Online mapping involving simultaneous editing of versioned data in an Esri Enterprise Geodatabase repository). Below, a list of issues with Offline Mapping functionality:

1. **Zoom Limitations:** Offline maps are limited to using Esri map templates, which have scale limitations (Maximum scale: 1:591,657,528 to 1:1,128). The current workaround is to sideload a custom map. But, the exercise of creating a map tile scheme in addition to sideloading it manually onto each device using collector is a time-consuming and inefficient.

2. **Unreliability:** During the Annie Street Plaza pilot, we encountered issues syncing data from the mobile device back to ArcGIS Online. In the end, 120 data points were lost (stuck on the iPad). Others on the Esri forums seemed to be having similar problems syncing data back to both AGOL and SDE.

   While we were able to figure out a workaround (see right panel) for saving the data in the end, we do not want to rely on a method where hours of in-field data collection are at risk.

3. **Editor Tracking:** Using an ArcSDE backend setup, there are limitations on what metadata you can collect with editor tracking. Specifically, the issue owes to the fact that secured services are not compatible with offline maps. While a user is able to collect metadata about the time the data was collected & edited (albeit in UTC time), the collector name appears as Esri Anonymous. The workaround is simply bulk-editing the Editor Name in post-data collection cleanup.

---

**TIP: Salvage ‘Un-Syncable’ Data from a Mobile Device:**

1. Connect device to computer with a USB cable, and open up Esri Collector in iTunes.
2. Save the geodatabase files from the Collector folder to your computer.
4. Create a new File Geodatabase.
5. Run the Import XML Workspace Document tool.
6. When it asks for a ‘Target Geodatabase’ point it to the File Geodatabase you just created. The ‘Import File’ is the XML file from Step 2.
7. Repeat for each of the geodatabase files.
RESOURCES

SFGIS RESOURCES

1. **Base Map Layers**
   
   I:\GIS\Citywide\base_maps\san francisco\SDELayers

2. **SFGIS Public Image Service**
   

ESRI ONLINE CONTENT

3. **ArcGIS Field Data Types**
   

4. **A quick tour of working with CAD data**
   

5. **Configure feature service data for offline use**
   

6. **Create Your Own Collector Map (with Domains and Subtypes)**
   
   http://www.esri.com/esri-news/arcuser/summer-2013/create-your-own-collector-map

7. **Creating and Publishing Maps with Relationships**
   

8. **Disconnected editing and sync**
   

9. **Editor Permissions for Feature Services**
   
   http://resources.arcgis.com/en/help/main/10.1/#/Editor_permissions_for_feature_services/015400000393000000/Options

10. **Feature class basics**
    
11. **Georeferencing a raster dataset**

12. **How to create a tile package**

13. **Related Tables – Exploring New Ways to use Collector for ArcGIS**

14. **Take Maps Offline**

15. **Tuning and configuring services**

16. **Types of geodatabases**
<table>
<thead>
<tr>
<th>Figure</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>“OLD-SCHOOL” WORKFLOW</td>
<td>9</td>
</tr>
<tr>
<td>02</td>
<td>“NEW-SCHOOL” WORKFLOW</td>
<td>10</td>
</tr>
<tr>
<td>03</td>
<td>GEODATABASE SETUP</td>
<td>13</td>
</tr>
<tr>
<td>04</td>
<td>MAP SETUP</td>
<td>20</td>
</tr>
<tr>
<td>05</td>
<td>MAP SERVICE SETUP</td>
<td>23</td>
</tr>
<tr>
<td>06</td>
<td>MOBILE DEVICE SETUP</td>
<td>29</td>
</tr>
<tr>
<td>07</td>
<td>BASEMAP SELECTION</td>
<td>31</td>
</tr>
<tr>
<td>08</td>
<td>DATA COLLECTION</td>
<td>33</td>
</tr>
<tr>
<td>09</td>
<td>POST-COLLECTION WORKFLOW</td>
<td>35</td>
</tr>
</tbody>
</table>
AGOL: An acronym for ArcGIS Online (http://arcgisonline.com).

Archiving: Storing records for changes made to data, which allows data collected in-field to be synchronized and appended to the feature service.

Coded Values: A property of domains that limits the values that a user can enter into a text field; allows a user to choose a value from a drop-down list.

Coordinate System: A three-dimensional reference system that can be attached to data in order to fix it to a specific location on Earth’s surface.

Domain: Rules that define and constrain the possible values of a field type of a feature class. A way to ensure standardized data entry.

Enterprise Geodatabase: A geodatabase that can be edited and used simultaneously by many users over time.

Feature Class: A data source composed of features with similar geometries (point, line, or polygon) and attributes.

Feature Dataset: A set of feature classes that share various properties.

Geodatabase: A “container” used to store datasets.

Map Service: A hosted map resource that can be used and viewed by many users.

Public Image Service (SFGIS): A cached map file that is hosted on the city’s server and can be included in maps for a wider range of zooming options.

Public Life Studies: An architectural and sociological discipline that attempts to understand how public spaces function through systematic observational surveys.

SDE: An acronym for Esri Spatial Data Engine (also known as Enterprise Geodatabase). A Connector between Esri ArcGIS clients and any enterprise geodatabase platforms (for example PostgreSQL, SQL Server, or Oracle).

Secured Service: A locked map layer that requires credentials to view and/or edit its content and/or properties.

Sideload: Manually loading a file onto a device without the use of an internet connection.

Subtypes: A categorization of features in a feature class, or objects in a table, that share the same attributes.
**Versioning:** A way of viewing a geodatabase that creates a new table for each editing session. Allows all users connected to a data source to track data edits.
### Gender

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Male</td>
<td>MALE</td>
</tr>
<tr>
<td>Female</td>
<td>FMAL</td>
</tr>
</tbody>
</table>

### Age

<table>
<thead>
<tr>
<th>Age</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>9 or Under</td>
<td>9</td>
</tr>
<tr>
<td>10 - 15</td>
<td>15</td>
</tr>
<tr>
<td>15 - 64</td>
<td>64</td>
</tr>
<tr>
<td>65 and Over</td>
<td>65</td>
</tr>
</tbody>
</table>

### Posture

<table>
<thead>
<tr>
<th>Posture</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Standing</td>
<td>PSTN</td>
</tr>
<tr>
<td>Standing - Leaning</td>
<td>PLN</td>
</tr>
<tr>
<td>Sitting Formal</td>
<td>PSTF</td>
</tr>
<tr>
<td>Sitting - Public - Fixed</td>
<td>PSTF</td>
</tr>
<tr>
<td>Sitting - Public - Mobile</td>
<td>PSTM</td>
</tr>
<tr>
<td>Sitting Formal (Wheelchair)</td>
<td>PSTW</td>
</tr>
<tr>
<td>Sitting Informal</td>
<td>PSTM</td>
</tr>
<tr>
<td>Sitting Improvised</td>
<td>PSTM</td>
</tr>
<tr>
<td>Lying</td>
<td>PLY</td>
</tr>
</tbody>
</table>

### Activities

<table>
<thead>
<tr>
<th>Activities</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Perform / Cultural</td>
<td>ACUL</td>
</tr>
<tr>
<td>Commerce</td>
<td>ACOM</td>
</tr>
<tr>
<td>Commerce (Informal)</td>
<td>ACMI</td>
</tr>
<tr>
<td>Eating / Drinking</td>
<td>AEAT</td>
</tr>
<tr>
<td>Electronic Device</td>
<td>AELC</td>
</tr>
<tr>
<td>Talking with One Another</td>
<td>ATAK</td>
</tr>
<tr>
<td>People Watching</td>
<td>APWA</td>
</tr>
<tr>
<td>Waiting for Transit</td>
<td>ATRN</td>
</tr>
<tr>
<td>Children Playing</td>
<td>ACHI</td>
</tr>
<tr>
<td>Accompanied by Pets</td>
<td>APET</td>
</tr>
</tbody>
</table>

### Other Activities

<table>
<thead>
<tr>
<th>Other Activities</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Smoking</td>
<td>ASMK</td>
</tr>
<tr>
<td>Intoxication</td>
<td>ANTX</td>
</tr>
<tr>
<td>Sleeping</td>
<td>ASLP</td>
</tr>
<tr>
<td>Panhandling</td>
<td>SPAN</td>
</tr>
</tbody>
</table>

### Objects / Nuisance

<table>
<thead>
<tr>
<th>Objects / Nuisance</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Urine / Defecation</td>
<td>OPEE</td>
</tr>
<tr>
<td>Litter / Debris</td>
<td>OLIT</td>
</tr>
<tr>
<td>Luggage / Belongings</td>
<td>OBAG</td>
</tr>
<tr>
<td>Stroller</td>
<td>OSTR</td>
</tr>
<tr>
<td>Pushcart</td>
<td>OCRT</td>
</tr>
</tbody>
</table>

### Bikes

<table>
<thead>
<tr>
<th>Bikes</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Parked (Rack)</td>
<td>BIK1</td>
</tr>
<tr>
<td>Parked (Other)</td>
<td>BIK2</td>
</tr>
<tr>
<td>Empty Rack</td>
<td>BIK3</td>
</tr>
<tr>
<td>On Bike Rack</td>
<td>BRAK</td>
</tr>
<tr>
<td>Bike on Other</td>
<td>BOTH</td>
</tr>
<tr>
<td>Bike on Corral</td>
<td>BCOR</td>
</tr>
</tbody>
</table>

### Vehicles

<table>
<thead>
<tr>
<th>Vehicles</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Moto - Scooter</td>
<td>01</td>
</tr>
<tr>
<td>Car</td>
<td>02</td>
</tr>
<tr>
<td>Van</td>
<td>03</td>
</tr>
<tr>
<td>Truck</td>
<td>04</td>
</tr>
<tr>
<td>Parked</td>
<td>VPKD</td>
</tr>
<tr>
<td>Loading</td>
<td>VLOD</td>
</tr>
<tr>
<td>Double-Parked</td>
<td>VDPK</td>
</tr>
<tr>
<td>Empty Parking Space</td>
<td>VEMP</td>
</tr>
<tr>
<td>Parked Illegally</td>
<td>VPKI</td>
</tr>
</tbody>
</table>

**NOTE:** Blue values not used in MDC Pilot
Robin Abad Ocubillo  
*CPC, Citywide*  
robin.abad@sfgov.org

Teresa Ojeda  
*CPC, Citywide*  
teresa.ojeda@sfgov.org

Brian Quinn  
*Department of Technology*  
brian.quinn@sfgov.org

Gene Stroman  
*CPC, Citywide*  
stromangd@gmail.com

Mike Webster  
*CPC, Citywide*  
michael.webster@sfgov.org

Mike Wynne  
*CPC, OASIS*  
mike.wynne@sfgov.org